What are the browser requirements to use DOULIX?

For best performance, please use Google Chrome

Windows Explorer < 11.0 is no longer supported. 

LIKE THIS ARTICLE? 

Share on facebook
Share on twitter
Share on linkedin